AudioAficionado.org  

Go Back   AudioAficionado.org > Manufacturers Forums > Audio Research

Audio Research State of the Art Audio Reproduction

Reply
 
Thread Tools Display Modes
  #51  
Old 04-30-2016, 04:58 AM
Royville Royville is offline
Junior Member
 
Join Date: Apr 2016
Posts: 2
Default New Member

Hello to all,

Greetings from the UK, I am a new member just joined today and my name is Roy (as I'm sure you can gather from my user name).

My reason for joining is that I'm in the market for a new pre amplifier and I'm seriously considering making a purchase of an SP20 pre.
I actually have one at the moment on home demo (second-hand) and I have to say that after only two days of listening I'm blown away! - I can honestly say I've never heard anything quite like it before. I love it! I find myself being drawn into the music like never before playing track after track, and then at the end I'll play 'just one more' then after that 'just one more' then after that . . .
In my system it produces a big sound with a good sound stage, and sense of reality I've never heard before. Deep and powerful bass, but so controlled and tuneful. Cymbals so real, like wood tapping on metal and vocals and everything all sounding just right.

I'm convincing myself more and more to make the purchase, - but I just seem to be having one problem, and its not the touch screen, or the slight vagueness of the rotary knobs; Its the remote! Beautifully made and very rugged too, but it doesn’t seem to work very well. Its fine up to about 2ft away but any further and it takes lots of presses and only wants to work directly in front of the unit. I've fitted new batteries but to no avail.
I'm left wondering whether the remote is faulty or is it something in the preamp itself.
This could be a deal breaker for me and I was wondering if any one else has had any similar problems?
Any advice or comments would be greatly appreciated.
Thanks for reading.
Kind regards
Roy.
Reply With Quote
  #52  
Old 04-30-2016, 11:57 AM
2fastdriving's Avatar
2fastdriving 2fastdriving is offline
Senior Member


 
Join Date: Jan 2013
Location: Seattle, WA
Posts: 5,560
Default

Quote:
Originally Posted by Royville View Post
Hello to all,

Greetings from the UK, I am a new member just joined today and my name is Roy (as I'm sure you can gather from my user name).

My reason for joining is that I'm in the market for a new pre amplifier and I'm seriously considering making a purchase of an SP20 pre.
I actually have one at the moment on home demo (second-hand) and I have to say that after only two days of listening I'm blown away! - I can honestly say I've never heard anything quite like it before. I love it! I find myself being drawn into the music like never before playing track after track, and then at the end I'll play 'just one more' then after that 'just one more' then after that . . .
In my system it produces a big sound with a good sound stage, and sense of reality I've never heard before. Deep and powerful bass, but so controlled and tuneful. Cymbals so real, like wood tapping on metal and vocals and everything all sounding just right.

I'm convincing myself more and more to make the purchase, - but I just seem to be having one problem, and its not the touch screen, or the slight vagueness of the rotary knobs; Its the remote! Beautifully made and very rugged too, but it doesn’t seem to work very well. Its fine up to about 2ft away but any further and it takes lots of presses and only wants to work directly in front of the unit. I've fitted new batteries but to no avail.
I'm left wondering whether the remote is faulty or is it something in the preamp itself.
This could be a deal breaker for me and I was wondering if any one else has had any similar problems?
Any advice or comments would be greatly appreciated.
Thanks for reading.
Kind regards
Roy.
Welcome to AA! I borrowed one once a few years ago, and had the same problem. It's not you. I think there was some tricks to make it work better but I was disappointed in the remote as well as the vague feeling panel control.
__________________
--Marc

Audio Research Ref6SE, Ref160M's / Esoteric K-01X, G-02X, E-03 / Wilson Alexia / Clearaudio Ovation with Universal Tonearm / Lyra Kleos / Transparent Reference Gen5 / Shunyata Denali 6000S V2, Sigma USB, Clock50, Sigma and Alpha HC PC's / HRS S3 Isolation bases / Roon, Tidal, Qobuz Intel NUC / SoTM SMS-200 Ultra Neo SE / Uptone EtherREGEN / Vicoustics, GIK Acoustics panels
Reply With Quote
  #53  
Old 05-01-2016, 07:51 AM
Royville Royville is offline
Junior Member
 
Join Date: Apr 2016
Posts: 2
Default

Hi Marc,

Thanks for your response and welcome.
Do you know what the fix was by any chance? If I can get satisfaction from the remote then I think I would buy.

I see you have the Ref 5SE pre, how does it compare with the SP20? - Does the remote for that work alright?
I too have the 10x5 but mine is on an LP12/ITTOK LVII - good combination, though I preferred the previous 10x4.

Hoping I get sorted.
Regards
Roy.
Reply With Quote
  #54  
Old 05-01-2016, 04:35 PM
docdan50 docdan50 is offline
Junior Member
 
Join Date: Jul 2011
Posts: 19
Default

Arc has an update. I had to send my sp20 in and once I got it back the remote worked much better.
Reply With Quote
  #55  
Old 04-06-2017, 01:05 PM
afridi's Avatar
afridi afridi is offline
Member
 
Join Date: Jun 2013
Location: Fargo ND
Posts: 31
Default

Sorry to raise an old thread from the ashes.

I just picked up an SP20 for home audition. Its replacing a McIntosh C47 and feed a Plinius SA103 into Focal Diablo speakers plus REL G1 sub.

While it does not have the looks of the traditional AR equipment I am not bothered by the touch screen. Use it to set things up and then never need to play with it again.

I find that it sounds absolutely wonderful. Im not able to describe audio very well but will say that I find myself drawn to longer listening sessions with this preamp in my system than with the McIntosh that resided previously. It has an absolutely stonking phono stage, and is way better than what I remember my Plnius Phono stage that I had a few years back (and that was a good phono-stage). It certainly sounds better than the C47 phono section.

I do think it is a very revealing pre in that poor recordings sound poor through it, and in some was it sounds detailed but not analytical. Im always drawn to the performance rather than getting stuck with some minor aspect of the sound.

Yeah, for me this is a good preamp and I plan to spend many years with it!
__________________
AFRIDI
Reply With Quote
  #56  
Old 04-06-2017, 08:55 PM
JBT JBT is offline
Member
 
Join Date: Jul 2009
Location: Lago Vista Texas Downtown Austin and Frisco Colorado
Posts: 1,653
Default

Congrats on your new amp!
Reply With Quote
  #57  
Old 04-09-2017, 05:53 PM
afridi's Avatar
afridi afridi is offline
Member
 
Join Date: Jun 2013
Location: Fargo ND
Posts: 31
Default

I had moved to my new place in Dec 2016. Yesterday I upgraded the outlets for my Stereo setup. I put in an Oyaide R1 for the main system as well as PS Audio outlet which feeds my REL sub. Boom! Suddenly more detail. But smoother. Also finding I'm running my system at a lower volume. I do plan to try some Herbies tube dampers and am curious about trying a synergistic research black fuse (while I know the rating I'm not sure what size fuse fits in the AR).

I think the AR SP20 and the Plinius play superbly together. I have listened to my systems over the years a lot. And I was always swapping gear but now, I feel I have reached where I want to be. I just turn it on and get lost in the music. I don't over analyze it, don't feel something is missing, or that I have to do something to it, and there is no fatigue.

This is true audio nirvana!
__________________
AFRIDI
Reply With Quote
  #58  
Old 04-12-2017, 08:25 PM
william t william t is offline
Junior Member
 
Join Date: May 2013
Posts: 3
Default carts

Hi there,, what carts are you using with the phono section mm or mc- Whats plays best with the sp20? Thinking on getting one before record store day--thanks
Reply With Quote
  #59  
Old 04-13-2017, 04:02 AM
afridi's Avatar
afridi afridi is offline
Member
 
Join Date: Jun 2013
Location: Fargo ND
Posts: 31
Default

Using a Clearaudio Concerto v2
__________________
AFRIDI
Reply With Quote
  #60  
Old 09-11-2020, 06:13 PM
amaglioc amaglioc is offline
Junior Member
 
Join Date: Jul 2016
Posts: 10
Default carts and SP20

Quote:
Originally Posted by william t View Post
Hi there,, what carts are you using with the phono section mm or mc- Whats plays best with the sp20? Thinking on getting one before record store day--thanks
Well this is an ancient thread about a now relatively (in ARC years?) older component, but in the interest of helping future searchers, I chose the Ortofon MC Cadenza Blue for my VPI Prime because the .5 mV output was in the sweet spot of SP20’s 58db phono stage gain. That was four years ago and it still sounds terrific.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Audioaficionado.org tested by Norton Internet Security

All times are GMT -4. The time now is 10:00 AM.



Powered by vBulletin® Version 3.8.10
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
©Copyright 2009-2019 AudioAficionado.org.Privately owned, All Rights Reserved.
Audio Aficionado Sponsors
AudioAficionado Subscriber
AudioAficionado Subscriber
Inspire By Dennis Had
Inspire By Dennis Had
Harmonic Resolution Systems
Harmonic Resolution Systems
Wyred4Sound
Wyred4Sound
Dragonfire Acoustics
Dragonfire Acoustics
GIK Acoustics
GIK Acoustics
Esoteric
Esoteric
AC Infinity
AC Infinity
JL Audio
JL Audio
Add Powr
Add Powr
Legend Audio & Video
Legend Audio & Video
Audio by E
Audio by E
Canton
Canton
Bryston
Bryston
WireWorld Cables
WireWorld Cables
Stillpoints
Stillpoints
Bricasti Design
Bricasti Design
Furutech
Furutech
Shunyata Research
Shunyata Research
Accuphase
Accuphase