AudioAficionado.org  

Go Back   AudioAficionado.org > Manufacturers Forums > McIntosh Audio

McIntosh Audio A Tradition of Excellence

Reply
 
Thread Tools Display Modes
  #101  
Old 06-03-2016, 05:43 AM
romavictor romavictor is offline
Senior Member
 
Join Date: Feb 2016
Posts: 133
Default

Well I brought it in to my dealer thinking it's gonna need repairs but thank goddess all it needed was the USB update which was done at the dealers.

Everything seems to be working fine now although something really weird happened the other day where an unknown source was displayed but after cycling through the choices, it went away.

In any case, it's a pain dealing with updating Mcintosh gear. They should have the foresight to make the whole damn process simple and efficient.
Reply With Quote
  #102  
Old 09-11-2017, 04:48 AM
j0rgan j0rgan is offline
Junior Member
 
Join Date: Sep 2017
Posts: 1
Default

For anyone getting into trouble with "Device Initialization Failed" this is how I solved it. I have done this from Windows 7 32bit installed on Virtualbox running on Mac.

1) Assuming that you installed everything as suggested, download the newest version of FLIP from http://www.atmel.com/tools/flip.aspx (At the time of writing this the last version is 3.4.7, thus change that when moving to Program Files folder)
2) (My) c2500 uses at32uc3a3256 chip from Atmel and FLIP doesn't have GUI version of at32uc3a3256 to load, so it has to be flashed from command line interface using batchisp.exe.
3) Move firmware.elf from C:\Program Files\McIntosh Laboratory\USB Audio Update\bin to C:\Program Files\Atmel\Flip 3.4.7\bin
4) Connect USB, open cmd.exe and switch to C:\Program Files\Atmel\Flip 3.4.7\bin
5) Issue the following commands one by one:
set DFU=batchisp -device at32uc3a3256 -hardware usb
%DFU% -operation erase f memory flash blankcheck loadbuffer firmware.elf program verify
%DFU% -operation start reset 0

6) Switch off c2500, unplug the usb cable, wait for few seconds and turn it on again


That should be it.

My 2c.
Reply With Quote
  #103  
Old 09-11-2017, 06:39 PM
krustycat's Avatar
krustycat krustycat is offline
Senior Member
 
Join Date: Dec 2014
Location: Long Island, NY
Posts: 908
Default

Thank you, this is very good information.
__________________
Mike -- B&W 802 D3 x 2, HTM1 D3, CM10 x 2, JL Audio F113 v2, SVS PB-12 Plus for LFE rear, McIntosh C2500 Tungsram ECC83/12AX7 NOS 1971 Hungary, McIntosh MC601 x 2, MC8207, MEN220, Esoteric K-03x, CAPS v4 Pipeline, NAS: Synology, WireWorld Silver El. 7 2.0m x 3, Silver Ec. 7 1.5m x 2, Platinum St. 7 USB 1.0m, Marantz AV8802a, 4 dedicated 20 A lines with Cruzefirstaudio Maestro Outlets. Primacoustic London 16 | Acoustic Panel Room Kit.
Reply With Quote
  #104  
Old 12-17-2018, 12:02 AM
armyslowrdr's Avatar
armyslowrdr armyslowrdr is offline
Junior Member
 
Join Date: Feb 2018
Location: Killeen/Fort Hood area
Posts: 26
Default

Well I will be awaiting my solution(s) from Rick at AC tomorrow. I too when powering on the C2500 got the no response behavior today--all the reset stuff got me was the meters and row of LED lighting up. So I imagine he will be sending along a firmware software and instructions. Fingers crossed. Unit has behaved flawlessly since February when I got it. Only thing I can think of was I was updating my graphics card driver yesterday so I could run Luminar on my PC. In process I rebooted computer several times. I did not even think about the effects of having the audioquest dragonfly output plugged in to the preamp. But what else could it have not liked....
__________________
EAT, McIntosh, Luxman, TEAC, EPOS, SVS
Reply With Quote
  #105  
Old 12-18-2018, 05:57 PM
armyslowrdr's Avatar
armyslowrdr armyslowrdr is offline
Junior Member
 
Join Date: Feb 2018
Location: Killeen/Fort Hood area
Posts: 26
Default

On its way for repair as running firmware to update did nothing. Will be using the Luxman again for a while.
__________________
EAT, McIntosh, Luxman, TEAC, EPOS, SVS
Reply With Quote
  #106  
Old 09-10-2019, 10:00 PM
superspirit superspirit is offline
Junior Member
 
Join Date: Apr 2019
Posts: 1
Default

Where can I download firmware.elf or usb audio update files.Thank you
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Audioaficionado.org tested by Norton Internet Security

All times are GMT -4. The time now is 02:37 AM.



Powered by vBulletin® Version 3.8.10
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
ęCopyright 2009-2019 AudioAficionado.org.Privately owned, All Rights Reserved.
Audio Aficionado Sponsors
AudioAficionado Subscriber
AudioAficionado Subscriber
Inspire By Dennis Had
Inspire By Dennis Had
Harmonic Resolution Systems
Harmonic Resolution Systems
Wyred4Sound
Wyred4Sound
Dragonfire Acoustics
Dragonfire Acoustics
GIK Acoustics
GIK Acoustics
Esoteric
Esoteric
AC Infinity
AC Infinity
JL Audio
JL Audio
Acoustic Sciences Corportation
Acoustic Sciences Corportation
Legend Audio & Video
Legend Audio & Video
Audio by E
Audio by E
Canton
Canton
Bryston
Bryston
WireWorld Cables
WireWorld Cables
Stillpoints
Stillpoints
Bricasti Design
Bricasti Design
Furutech
Furutech
Shunyata Research
Shunyata Research
Accuphase
Accuphase